sony vgn-sr15

우분투를 지원하는 하드웨어 정보 및 리뷰의 장입니다., 질문/답변장이 아닙니다.

Moderator: Dry8r3aD

Post Reply
Posts: 16
Joined: 2008/07/17 Thu 8:39 am

sony vgn-sr15

Post by 5sec » 2008/10/27 Mon 8:32 am

내장그래픽 intel X4500(G45)을 사용하는 랩탑입니다.
현재는 X가 작동시에 화면에 아무것도 나타나지 않는 문제가 있습니다.

최종적으로 intrepid에 들어가는 xserver-xorg-video-intel 드라이버가 2.4.1-1ubuntu10 입니다.
[quote:38qjlqzb]xserver-xorg-video-intel (2:2.4.1-1ubuntu10) intrepid; urgency=low
* 28_stolen_memory_counting_g4x.patch:
- Fixes freeze on login for G45 hardware when runs in EXA mode.
Issue was fixed upstream in both the kernel and x driver. This
patch is also in Debian.
(LP: #285572)[/quote:38qjlqzb]

해결이 된 듯 하지만 소니 랩탑은 추가로 문제가 있더군요. 이건 2.5.0에서도 해결되지 못했습니다. ... 39555.html
[quote="[ANNOUNCE] xf86-video-intel 2.5.0 Jesse Barnes":38qjlqzb]The blocker list was almost completely cleared out. We still have a few
issues (including a Sony/GM45 related problem we still don't understand), but
overall all our bug fixers deserve a big thank you.

Posts: 16
Joined: 2008/07/17 Thu 8:39 am

Re: sony vgn-sr15

Post by 5sec » 2008/11/20 Thu 4:43 am

해결책이 나왔네요. 곧 업데이트가 될 것 같습니다.

[quote:3oy2odvv]Yesterday I tried updating libdrm and rebuilding mesa and xf86-video-intel, but
the compilation gives some errors, libdrm cannot be fully installed because
libtool complains about directories not ending in /usr/local/lib, which I don't
understand at all. For instance it says:

libtool: error: install: cannot copy '' into a directory not
ending in '/usr/local/lib'

I tried building and installing both on /opt/gfx-test, where I have everything
for testing, and even I tried a fresh distribution on a new partition of my
laptop where there was no Xorg at all and I downloaded the whole Xorg and built
from scratch, with the prefix /usr, trying to get it working there too.

But also in the latter I got many errors, such as aclocal complaining about
paths and libtool still complaining about directories not ending in
/usr/local/lib, so I don't know anymore what to do.

And since I use Debian, it will be quite a long time before I get any 2.5.x
driver on the distribution package, which sets me up even more.

I hope someone else is testing and is more capable of fixing this building
errors with paths, and I really hope we are really close to fixing this stupid

User avatar
Posts: 49
Joined: 2009/01/27 Tue 11:09 pm

Re: sony vgn-sr15

Post by azurenine » 2009/01/27 Tue 11:19 pm

이 문제가 드디어 해결이 되어 2.6.2에 패치가 포함된다는 소식입니다. ;)
소니 sr뿐만 아니라 z의 문제도 해결될 듯 보이네요.

Post Reply