xenial용 bomi-0.9.11 패키지를 공유 합니다.

좋은 프로그램, 한글화 파일, 그외 유용한 자료들

Moderator: Dry8r3aD

workman729
Posts: 531
Joined: 2014/02/12 Wed 5:02 pm

xenial용 bomi-0.9.11 패키지를 공유 합니다.

Postby workman729 » 2016/04/28 Thu 2:36 pm

이번에 xenial에선 ppa 버전의 bomi에서 의존성 에러가 있어 어떻게 해볼 도리가 없더군요!

그래서 소스를 약간 수정해서 xenial 용으로 재빌드해 보았습니다.
ffmpeg은 xenial에서 기본으로 설치되는 패키지를 이용하였으니 참고 하시기 바랍니다.

혹 라이브러리 이름에 ffmpeg의 이름이 붙고 안 붙고에 따라 의존성 에러가 발생할지도 모르겠다는 예상이 듭니다.

수정된 소스도 올려드리니 필요하시면 각자 빌드하시기 바랍니다.
Attachments
bomi_0.9.11ppa1~vivid1.tar.gz
(4.56 MiB) Downloaded 206 times

[The extension deb has been deactivated and can no longer be displayed.]


iloveapink
Posts: 16
Joined: 2016/03/21 Mon 10:21 am

Re: xenial용 bomi-0.9.11 패키지를 공유 합니다.

Postby iloveapink » 2017/08/09 Wed 11:01 pm

저 deb 파일도 같이 올려주시면 안되나요?
초보라 죄송합니다.

workman729
Posts: 531
Joined: 2014/02/12 Wed 5:02 pm

Re: xenial용 bomi-0.9.11 패키지를 공유 합니다.

Postby workman729 » 2017/08/10 Thu 10:28 am

죄송합니다. 현재 xenial을 사용하지 않습니다만 딱히 pbuilder를 이용하여 빌드할 기회가 없군요!

뭐 하시다면 mpv를 이용하시기 바라며 꼭 빌드가 필요 하시다면
devscript를 설치하신 후 빌드하시기 바랍니다.

먼저 control 파일의 의존 패키지명을 xenial 용으로(예: libavcodec-ffmpeg-dev를 libavcodec-dev) 수정 하시고 changelog를 추가 하신 뒤
다음과 같이 해 보시기 바랍니다.

# cd bomi-버전
# sudo apt-get builddep mpv
# cd debian
# sudo mk-build-deps --install control
# cd ..
# debuild

xenial은 ffmpeg 버전이 2.x 를 이용하므로 패치가 필요 없지만 만약 ppa등을 이용하여 3.x 버전을 이용하신 다면
패치가 필요 합니다.

일전에 페도라 사용자 모임의 자료실에 올려 둔 것이 있는 것 같습니다.
기회가 되신다면 방문하셔서 찾아 보시기 바랍니다.

올릴때 패키지도 함께 올렸습니다만 deb 확장자는 업로드 금지 되어 있어
삭제된 것으로 압니다.

시간이 제한적이라서요....! 양해 바랍니다.

Return to “자 료 실”

Who is online

Users browsing this forum: No registered users and 3 guests