사운드가 거의 들리지 않아요. ㅠㅠ

하드웨어 지원 및 드라이버 설치 등에 관한 문제 해결

Moderator: Dry8r3aD

User avatar
cklove
Posts: 1192
Joined: 2008/04/18 Fri 11:57 am
Location: 프랑스 몽펠리에
Contact:

사운드가 거의 들리지 않아요. ㅠㅠ

Postby cklove » 2017/11/29 Wed 11:29 pm

안녕들 하세요? 정말 오랜만에 이 커뮤니티 포럼에 들어 왔네요.
한동안 열심히 활동 했었는데, 페이스북 커뮤니티 생기고,
사이트가 너무 정신없이 여러 개로 만들어지던 그 시점부터 이상하게 발길을 끊다시피 했었던 것 같네지요.
오늘은 한 가지 여쭤보고 싶은 것이 있어 고수님들게 부탁을 드리려고 방문했어요.

제가 2005년도 윈도xp용 노트북에 우분투는 어려울 것 같아서 리눅스 민트를 설치했는데, 소리가 안나는 겁니다.
노트북이 켜질 때 스피어서 살짝 노이즈가 뜨는 것을 보면 하드웨어적으로는 문제가 없는 것 같고,
볼륨 컨트럴을 열어보면 사운드 게이지가 정상적으로 움직이는 것으로 보아 분명히 소리는 감지하는 것 같은데 소리가 안들립니다.
볼륨을 최대한으로 하고 헤드폰으로 들어보면 분명히 소리가 들리는 것은 확실한데 너무 작아서 거의 들리지 않네요.

그래서 민트 대신에 다시 루분투를 설치해 봤어요. 역시 마찬가지군요.

인터넷에서 여기 저기 검색하면서 해 봤는데 안 됩니다. 이럴 땐 어떻게 해야 할까요?

고수님들의 조언을 구합니다.
누군가가 당신을 위해 기도하고 있습니다 !
HP Pavilion 15-n027tx / ubuntu 14.04 (64)

workman729
Posts: 542
Joined: 2014/02/12 Wed 5:02 pm

Re: 사운드가 거의 들리지 않아요. ㅠㅠ

Postby workman729 » 2017/11/30 Thu 2:40 pm

오랫만에 뵙는군요....^^

사운드 카드가 뭔가요?

User avatar
cklove
Posts: 1192
Joined: 2008/04/18 Fri 11:57 am
Location: 프랑스 몽펠리에
Contact:

Re: 사운드가 거의 들리지 않아요. ㅠㅠ

Postby cklove » 2017/12/01 Fri 3:25 am

아, 안녕하세요?
벌써 답변을 주셨네요. ^^ 감사합니다.

오래된 삼보 노트북 Averatec 1500series이구요, 정보를 찾아보니 아래와 같네요.
사운드카드는
Audio device : Intel Corporation NM10/ICH7 Family High Definition Audio Controller (rev 02)
이것 맞지요?

그리고...
민트를 설치할 때는 문제 없었는데, 루분투를 설치했더니 부팅되자마자 슬립모드로 빠저 버리는 현상이 발생하네요.
이건 왜 그럴까요?



-PCI Devices-
Host bridge : Intel Corporation Mobile 945GM/PM/GMS, 943/940GML and 945GT Express Memory Controller Hub (rev 03)
VGA compatible controller : Intel Corporation Mobile 945GM/GMS, 943/940GML Express Integrated Graphics Controller (rev 03) (prog-if 00 [VGA controller])
Display controller : Intel Corporation Mobile 945GM/GMS/GME, 943/940GML Express Integrated Graphics Controller (rev 03)
Audio device : Intel Corporation NM10/ICH7 Family High Definition Audio Controller (rev 02)
PCI bridge : Intel Corporation NM10/ICH7 Family PCI Express Port 1 (rev 02) (prog-if 00 [Normal decode])
PCI bridge : Intel Corporation NM10/ICH7 Family PCI Express Port 2 (rev 02) (prog-if 00 [Normal decode])
USB controller : Intel Corporation NM10/ICH7 Family USB UHCI Controller #1 (rev 02) (prog-if 00 [UHCI])
USB controller : Intel Corporation NM10/ICH7 Family USB UHCI Controller #2 (rev 02) (prog-if 00 [UHCI])
USB controller : Intel Corporation NM10/ICH7 Family USB UHCI Controller #3 (rev 02) (prog-if 00 [UHCI])
USB controller : Intel Corporation NM10/ICH7 Family USB UHCI Controller #4 (rev 02) (prog-if 00 [UHCI])
USB controller : Intel Corporation NM10/ICH7 Family USB2 EHCI Controller (rev 02) (prog-if 20 [EHCI])
PCI bridge : Intel Corporation 82801 Mobile PCI Bridge (rev e2) (prog-if 01 [Subtractive decode])
ISA bridge : Intel Corporation 82801GBM (ICH7-M) LPC Interface Bridge (rev 02)
IDE interface : Intel Corporation 82801GBM/GHM (ICH7-M Family) SATA Controller [IDE mode] (rev 02) (prog-if 80 [Master])
SMBus : Intel Corporation NM10/ICH7 Family SMBus Controller (rev 02)
Network controller : Intel Corporation PRO/Wireless 3945ABG [Golan] Network Connection (rev 02)
FireWire (IEEE 1394) : O2 Micro, Inc. Firewire (IEEE 1394) (rev 02) (prog-if 10 [OHCI])
SD Host controller : O2 Micro, Inc. Integrated MMC/SD Controller (rev 01)
Mass storage controller : O2 Micro, Inc. Integrated MS/xD Controller (rev 01)
Ethernet controller : Realtek Semiconductor Co., Ltd. RTL-8100/8101L/8139 PCI Fast Ethernet Adapter (rev 10)
누군가가 당신을 위해 기도하고 있습니다 !
HP Pavilion 15-n027tx / ubuntu 14.04 (64)

User avatar
cklove
Posts: 1192
Joined: 2008/04/18 Fri 11:57 am
Location: 프랑스 몽펠리에
Contact:

Re: 사운드가 거의 들리지 않아요. ㅠㅠ

Postby cklove » 2017/12/02 Sat 7:28 pm

볼륨컨트롤에서 Output Devices 탭을 보면,
하드웨어가 "내장 오디오 아나로그 스테레오"라고 되어 있고
Port는 위의 사운드카드가 보이지 않고 "라인출력"이라고 된 것 하나만 뜨네요.
이게 원인인 것 같아요.

이것을 어떻게 하면 인텔 오디오 카드가 보이게 할 수 있을까요?
누군가가 당신을 위해 기도하고 있습니다 !
HP Pavilion 15-n027tx / ubuntu 14.04 (64)

workman729
Posts: 542
Joined: 2014/02/12 Wed 5:02 pm

Re: 사운드가 거의 들리지 않아요. ㅠㅠ

Postby workman729 » 2017/12/03 Sun 6:13 pm

답변이 늦었군요...^^ 최근에 윈도우 때문에 성질이 나서요!
윈도우10은 쓰지 맙시다.

일단 아래와 같이 해 보시기 바랍니다.

Code: Select all

$ aplay -l
aplay: device_list:268: no soundcards found...


위와 같이 나온다면 alsa가 찾지 못하는 것 입니다. 그렇다면 문제를 해결 할 수 없을 것으로 보입니다.

다만 상식상 snd-hda-intel 모듈은 이상 없이 로딩 될 것으로 보이므로 뭔가는 나올 겁니다.
아래와 같이 설정 후 alsa를 재로딩하여 확인해 보시기 바랍니다.

Code: Select all

# sudo vi /etc/modprobe.d/alsa-base.conf
options snd-hda-intel model=MODEL명


모델명을 모르시겠다면 auto 또는 basic 으로 설정하여 재로딩하십시오.
이의 재반 사항은 cat /proc/asound/card0/pcm0c/info으로 확인 가능하나 오래된 모델은 확인 불가능 합니다.
보통 메이커들의 상표명입니다.

Code: Select all

# sudo alsa force-reload


재부팅 후 소리 여부를 확인해 보시기 바랍니다.
다만 코덱 모듈 중 i82975x_edac이 업로딩되면 cracking과 pupping의 원인이 되므로 blaklist 처리 하시기 바랍니다.

Code: Select all

# lsmod | grep i82975x_edac
# sudo vi /etc/modprobe.d/blacklist.conf
blacklist i82975x_edac


설정 후 sudo update-initramfs -u 명령 처리 하신 뒤 재부팅해서 확인해 보시기 바랍니다.
없다면 무시 하셔도 됩니다.

행운을 빕니다.

볼륨컨트롤에서 Output Devices 탭을 보면,
하드웨어가 "내장 오디오 아나로그 스테레오"라고 되어 있고
Port는 위의 사운드카드가 보이지 않고 "라인출력"이라고 된 것 하나만 뜨네요.
이게 원인인 것 같아요.

이것을 어떻게 하면 인텔 오디오 카드가 보이게 할 수 있을까요?


원래 그렇게 뜹니다. 정상이구요.
오픈소스는 다 그래요...^^

## 추가 아래 링크도 참조해보세요. 소니난다네요 ###
같은 내용인데 모듈 내렸다 올리는 과정이 있어야 하는가 봅니다.
https://wiki.sabayon.org/index.php?titl ... ound_Cards

Return to “하드웨어 게시판”

Who is online

Users browsing this forum: No registered users and 1 guest