cmplayer에서 코덱이 자꾸 삭제되어 있네요.

음악, 동영상 등 멀티미디어 및 코덱과 관련된 문제 해결

Moderator: Dry8r3aD

runa99
Posts: 161
Joined: 2014/12/31 Wed 11:28 pm

cmplayer에서 코덱이 자꾸 삭제되어 있네요.

Postby runa99 » 2015/01/16 Fri 6:33 pm

Kazam_screenshot_00001.png
Kazam_screenshot_00001.png (74.77 KiB) Viewed 1733 times


vga 드라이버 업뎃하면서 원래는 mpeg4 빼고 다 체크 되어 있는건데
자꾸만 이런 상태로 바뀝니다.
글픽 카드 업뎃한 직후의 시스템 백업본으로 복구 시키면 다시 살아 있는데
또 잠시후 확인해 보면 지워져 있네요.
그래픽 드라이버 재설치로는 다시 안살아나고 이미지 복구로만 되네요.
반복.
왜 그럴까요?
글고 mpeg4 면 mp4 확장자 동영상을 말하는 건가요? 이건 원래 지원이 안되는지 궁금합니다.

workman729
Posts: 562
Joined: 2014/02/12 Wed 5:02 pm

Re: cmplayer에서 코덱이 자꾸 삭제되어 있네요.

Postby workman729 » 2015/01/16 Fri 11:07 pm

음!!! 추측하기엔 인텔 계열의 그래픽 카드를 사용하시는 것 같습니다.
아마도 온보드 형이겠지요?

CMplayer의 하드웨어 가속은 VA-API를 통해서 하드웨어 가속을 지원하는데
VA-API를 지원하는 각 그래픽카드의 드라이버에 따라서 실제로 사용가능한 코덱이 달라집니다.

CMplayer의 소스를 한번이라도 보셨다면 위의 가속이 디폴트 값이 아님을 아실 것이고
기본적으로 위의 설정이 해제되어 있도록 설정되어 있음을 알 수 있습니다.

왜냐면 하드웨어 가속이 항상 성능을 향상 시킬 수 있는 것도 아니고
어떤 코덱을 사용하느냐에 따라 성능을 저하 시킬 수도 있기 때문입니다.

아직 CMplayer는 개발 단계의 실험적 요소를 많이 내포하고 있고
자체 ffmpeg의 버전이 비교적 과거의 것이라 성능을 100% 활용하기가 어려울 것 입니다.

CMplayer는 mplayer의 백엔드이므로 앞으로 mplayer 또는 백엔드 중 가장 신뢰할 수 있는 smplayer를 이용하시거나
최신의 코덱과 가속 기능을 활용하시려면 kodi media player를 활용해 보십시오.

그리고 하드웨어 가속 기능은 독점 드라이버를 설치 하셨다면 이미 vaapi 가속 기능을 지원하므로
굳이 cmplayer에서 설정해 주실 필요 없습니다.

첨언을 하자면 각각의 동영상 플레이어는 범용의 하드웨어를 지원하고
opengl 버전 차에 따라 어떤 desktop enviroments를 사용하고 어떤 Compositor를 사용하느냐에 따라
하드웨어 가속 기능 지원이 될 수도 안 될 수도 있습니다.

보다 최신의 버전을 사용하는 동영상 플레이어로 변경해 보시기를 권해 드립니다.

일전에 bleachbit과 같은 유틸을 사용할 때 일부 하드웨어 관련 파일이 삭제되었다고 댓글을 쓰신 적이 있는 것 같습니다.
아마도 이것을 두고 말씀하신 것 같습니다만 이와는 전혀 무관함을 이해하시기 바랍니다.
Last edited by workman729 on 2015/01/16 Fri 11:19 pm, edited 1 time in total.

runa99
Posts: 161
Joined: 2014/12/31 Wed 11:28 pm

Re: cmplayer에서 코덱이 자꾸 삭제되어 있네요.

Postby runa99 » 2015/01/16 Fri 11:19 pm

감사합니다...
근데 인텔 온보드형 바로 맞추셨어요!!!

xbmc는 오리지날을 설치하면 하드웨어 가속은 되는데
한글폰트 적용이 안되고
ppa 최신 버젼은 한글폰트 적용은 되는데 하드웨어 가속은 안되서
못 쓰겠더군요.
디자인인이 참신했는데 아쉽 -_-

workman729
Posts: 562
Joined: 2014/02/12 Wed 5:02 pm

Re: cmplayer에서 코덱이 자꾸 삭제되어 있네요.

Postby workman729 » 2015/01/17 Sat 9:38 am

다 되는데요....?

runa99
Posts: 161
Joined: 2014/12/31 Wed 11:28 pm

Re: cmplayer에서 코덱이 자꾸 삭제되어 있네요.

Postby runa99 » 2015/01/17 Sat 12:27 pm

제 컴에서만 그런가 봐요 ^^;
뭐 이상함 -_-

글구...
sudo apt-get remove ---purge
때문인 것 같네요.
다른 동영상 플레이어를 지워서 cmp 설정도 변한듯.

workman729
Posts: 562
Joined: 2014/02/12 Wed 5:02 pm

Re: cmplayer에서 코덱이 자꾸 삭제되어 있네요.

Postby workman729 » 2015/01/17 Sat 1:03 pm

그렇지는 않습니다. 다른 동영상 플레이를 지웠다고 다른 어플의 설정이 변하고 하는 경우는 없습니다.

인텔의 드라이버 자체에 하드웨어 가속 기능을 반영한 것이 얼마 되지 않았고
cmplayer의 개발자는 한 분이라서 최신의 모든 것을 반영하기가 어렵습니다.

그리고 kodi media player의 스킨의 폰트를 arial로 변경하시거나
마음에 드는 스킨이 한글을 arial 폰트를 지원하지 않아도 ~/.kodi/addons/스킨명/fonts
위치에 있는 폰트들을 나눔폰트, 맑은고딕등을 같은 이름으로 심볼릭 링크를 걸고
언어 설정을 korea로 변경하면 모든 메뉴가 한글로 나올 것 입니다.

과거에는 하드웨어 가속 기능이나 동영상 기능 설정이 밖에 있었지만
현재는 모두 자동으로 지원하고 설정 메뉴는 동영상 플레이시 나오는 메뉴에 들어가 있습니다.

그리고 kodi는 vdpau, vaapi등의 기능이 자동으로 반영 되도록 되어 있습니다.
참고 하십시오.

runa99
Posts: 161
Joined: 2014/12/31 Wed 11:28 pm

Re: cmplayer에서 코덱이 자꾸 삭제되어 있네요.

Postby runa99 » 2015/01/17 Sat 1:27 pm

넵. 감사합니다.
글고 다시 확인해 봤는데 인텔 그래픽카드 드라이버 업그레이드 파일 때문이었어요.
감사합니다.

xylosper
Posts: 16
Joined: 2009/04/10 Fri 6:00 pm

Re: cmplayer에서 코덱이 자꾸 삭제되어 있네요.

Postby xylosper » 2015/01/18 Sun 9:07 pm

workman729 wrote:아직 CMplayer는 개발 단계의 실험적 요소를 많이 내포하고 있고
자체 ffmpeg의 버전이 비교적 과거의 것이라 성능을 100% 활용하기가 어려울 것 입니다.


비교적의 기준에 따라 다르겠지만 CMPlayer의 ffmpeg버전은 비교적 최신 것입니다.

workman729 wrote:CMplayer는 mplayer의 백엔드이므로 앞으로 mplayer 또는 백엔드 중 가장 신뢰할 수 있는 smplayer를 이용하시거나
최신의 코덱과 가속 기능을 활용하시려면 kodi media player를 활용해 보십시오.


CMPlayer는 mplayer에 의존하지 않으며 백엔드도 아닙니다.
CMPlayer는 mpv의 포크입니다.

workman729 wrote:그리고 하드웨어 가속 기능은 독점 드라이버를 설치 하셨다면 이미 vaapi 가속 기능을 지원하므로
굳이 cmplayer에서 설정해 주실 필요 없습니다.


인텔은 독점 드라이버가 없습니다.

workman729
Posts: 562
Joined: 2014/02/12 Wed 5:02 pm

Re: cmplayer에서 코덱이 자꾸 삭제되어 있네요.

Postby workman729 » 2015/01/18 Sun 9:17 pm

개발자님 맞으신 것 같은데요!

그런가요...! 소스를 참고한 것이 상당히 오래전이라 지금은 어떤지는 정확히 모르겠군요!
정확한 정보가 아니라면 정중히 사과의 말씀 드립니다.

일전에 저장소에 비해 업데이트가 된 것 같습니다. 저장소가 달라진 것 같기도 합니다.

물론 정확하게는 mpv를 이용하고 있는 것을 알고 있지만
mpv도 mplayer 기반이라서 그렇게 글을 쓴 점 인텔에서 배포하는 드라이버를 일반적으로 표현 한 것이니 양해 부탁드립니다.
Last edited by workman729 on 2015/01/18 Sun 9:30 pm, edited 2 times in total.

xylosper
Posts: 16
Joined: 2009/04/10 Fri 6:00 pm

Re: cmplayer에서 코덱이 자꾸 삭제되어 있네요.

Postby xylosper » 2015/01/18 Sun 9:20 pm

vainfo 를 실행해보시고 거기에 VAProfileMPEG4Simple/VAProfileMPEG4AdvancedSimple 프로필에 VAEntrypointVLD가 사용가능으로 뜬다면 문제가 있는 것이니 https://github.com/xylosper/bomi/issues 로 알려주세요.
해당 프로필이 없다면 그래픽카드에서 지원하지 않는 것입니다.

Return to “멀티미디어/코덱 게시판”

Who is online

Users browsing this forum: No registered users and 1 guest