cpu 점유율 100% 우분투 9.10 좀 도와주세요~ 리눅서님들

데스크탑 꾸미기(compiz)/소프트웨어 설치 및 설정에 관한 문제 해결

Moderator: Dry8r3aD

Post Reply
vampard
Posts: 2
Joined: 2009/11/20 Fri 12:01 am

cpu 점유율 100% 우분투 9.10 좀 도와주세요~ 리눅서님들

Post by vampard » 2009/11/20 Fri 2:26 am

윈도우 유저였다가 지금 리눅스를 한번 시작해볼려구 하거든요~

예전에 센트OS를 공부한적있었지만..

이번에 리눅스 9.10을 설치했습니다.

하지만 저희 집 컴은 윈도우 xp보다 못하더군요~

그냥 음악틀고 영화 틀고 서칭하는데

이세가지중에 어느 2가지만 하면 cpu점율이 100퍼센트가 되어서

음악 재생창 바는 빠른 속도로 넘어가고 소리는 나오지 않게 됩니다.

음악을 틀고 멀티 태스킹을 하면 cpu 점유율이 100이 되어버립니다.

윈도우 xp를 쓸때는 그정도는 정말 아무탈없이 되었었는데...

설정문제일까도 봤지만 사운드는 설정은 정상이였구요 그래픽드라이버도

nvidia FX 5200 인데 nvidia server setting 과 nvidia xorg 173

으로 세팅되어있어요

제가 그래픽 드라이버를 잘못 깔은건가요?
사운드카드를 새로 깔아야하나요?
cm8738에 맞게 설치되었는데.. 프로파일은 analog stereo duplex이구요
아니면 음악 재생기에 문제일까요? 아마록 밴쉬 리듬박스

모두 다 똑같더군요~ cpu 100%

아니면 제 컴퓨터 사양이 낮은 걸까요?

제 컴퓨터 사양은

cpu: 펜티엄4 1.7
램: 1기가
그래픽: 지포스 FX 5200
하드: 200기가
사운드: c-media cm8738

넷북에서도 아무이상없이 돌아간다던데...
시스템 최적화 할려구 그래픽 프로그램 compiz이런것도 지우고
가상채널도 1개만 사용하거든요
가볍다는 리눅스가 윈도우 xp보다 못하다는것은

제 컴에 무슨 문제가 있지않을까요?

도무지 모르겠네요~ 고수님들 좀 알려주세요~!!!

데비안
Posts: 86
Joined: 2009/11/04 Wed 9:04 pm

Re: cpu 점유율 100% 우분투 9.10 좀 도와주세요~ 리눅서님들

Post by 데비안 » 2009/11/20 Fri 2:47 pm

[code:ndpu3wro]ps aux[/code:ndpu3wro]
또는
[code:ndpu3wro]gnome-system-monitor[/code:ndpu3wro]
을 실행하여 우선, 문제가 되는 프로그램이 어떤 것인지 확인해야 됩니다.

kildin
Posts: 46
Joined: 2009/01/15 Thu 7:08 am

Re: cpu 점유율 100% 우분투 9.10 좀 도와주세요~ 리눅서님들

Post by kildin » 2009/11/20 Fri 4:52 pm

Intel P4M 1.6, RAM 512M 짜리 노트북에 우분투를 설치한 적이 있습니다만...
저도 Windows XP보다 느렸던 걸로 기억합니다.

우분투가 XP보다 빠르진 않은 것 같더군요.

User avatar
coreanlibero
Posts: 1488
Joined: 2008/07/30 Wed 4:19 pm
Location: Seoul, Korea
Contact:

Re: cpu 점유율 100% 우분투 9.10 좀 도와주세요~ 리눅서님들

Post by coreanlibero » 2009/11/20 Fri 10:43 pm

[quote="vampard":1wzxr8ka]윈도우 유저였다가 지금 리눅스를 한번 시작해볼려구 하거든요~

예전에 센트OS를 공부한적있었지만..

이번에 리눅스 9.10을 설치했습니다.

하지만 저희 집 컴은 윈도우 xp보다 못하더군요~

그냥 음악틀고 영화 틀고 서칭하는데

이세가지중에 어느 2가지만 하면 cpu점율이 100퍼센트가 되어서

음악 재생창 바는 빠른 속도로 넘어가고 소리는 나오지 않게 됩니다.

음악을 틀고 멀티 태스킹을 하면 cpu 점유율이 100이 되어버립니다.

윈도우 xp를 쓸때는 그정도는 정말 아무탈없이 되었었는데...

설정문제일까도 봤지만 사운드는 설정은 정상이였구요 그래픽드라이버도

nvidia FX 5200 인데 nvidia server setting 과 nvidia xorg 173

으로 세팅되어있어요

제가 그래픽 드라이버를 잘못 깔은건가요?
사운드카드를 새로 깔아야하나요?
cm8738에 맞게 설치되었는데.. 프로파일은 analog stereo duplex이구요
아니면 음악 재생기에 문제일까요? 아마록 밴쉬 리듬박스

모두 다 똑같더군요~ cpu 100%

아니면 제 컴퓨터 사양이 낮은 걸까요?

제 컴퓨터 사양은

cpu: 펜티엄4 1.7
램: 1기가
그래픽: 지포스 FX 5200
하드: 200기가
사운드: c-media cm8738

넷북에서도 아무이상없이 돌아간다던데...
시스템 최적화 할려구 그래픽 프로그램 compiz이런것도 지우고
가상채널도 1개만 사용하거든요
가볍다는 리눅스가 윈도우 xp보다 못하다는것은

제 컴에 무슨 문제가 있지않을까요?

도무지 모르겠네요~ 고수님들 좀 알려주세요~!!![/quote:1wzxr8ka]
원본 지키미입니다...;;;
재성才誠 LT blog, Twitter

E-mail, Gtalk jaesung (at) liberotown (dot) com
IRC 재성 @irc.hanirc.org #ubuntu, Jaesung @irc.ubuntu.com #ubuntu-ko
ASUS F83Vf-VX009V Intel Core2Duo P8700, RAM 4GB, GeForce GT 220M

dooram
Posts: 194
Joined: 2009/01/12 Mon 10:18 am

Re: cpu 점유율 100% 우분투 9.10 좀 도와주세요~ 리눅서님들

Post by dooram » 2009/11/21 Sat 12:17 am

저랑 같은 증상이시네요..
저는 지포스 6200인데요.
...해결못봣습니다. ㅠㅠ

vampard
Posts: 2
Joined: 2009/11/20 Fri 12:01 am

Re: cpu 점유율 100% 우분투 9.10 좀 도와주세요~ 리눅서님들

Post by vampard » 2009/11/24 Tue 2:33 am

ps aux 시스템 감시.. 등의 명령어로 인해...

머가 프로세스를 많이 잡아먹는지 당연히 압니다.


제가 엠피쓰리 프로그램을 켰을때

다른 작업을 하면.. 가령 파이어폭스를 키거나.

그냥 우분투 프로그램 아무거나 실행을 하나 더 했을때...

멀티태스킹이라고 하죠~

cpu100% 인데.............................

이를 어떻게 해결해야하죠???

프로세스많이 잡아 먹는것을 끄면 되나요??

그럼 저는 멀티태스킹을 하지말라는 말인데~~ ㅎㅎ

먼가 다른 방법이 없을까~~요????

heodh
Posts: 65
Joined: 2009/09/24 Thu 3:57 pm

Re: cpu 점유율 100% 우분투 9.10 좀 도와주세요~ 리눅서님들

Post by heodh » 2009/11/24 Tue 10:06 am

아무 작업을 안해도 부팅 후 멀티태스킹을 하고 있는 상황일겁니다. 내부적으로......

그리고 ps aux 결과를 이 곳에 올려주시는게 도움이 될 것 같습니다.

그리고 또 하나 '시작 프로그램'인지 '서비스' 인지, 항목에서 불필요한 것들은 선택 '해제'를 하고 재부팅 하시면 일단은 조금이나마 시스템 자원을 확보할 수 있을 겁니다.

파이어 폭스를 사용 할 때 혹시 플래쉬가 많은 사이트를 방문하는 것은 아닌지 모르겠습니다. 예전에 파이어폭스로 인한 CUP 점유율이 높아지는 문제가 있었던 기억이 있습니다. 제 경우는 아니었지만.

사실 컴터 사양이 큰 문제는 아닐 것 같습니다. 제가 최근까지 사용하던 노트북이 센트리노 1.2 램 512 였는데, 속도야 느리긴 했겠지만 CPU 100 정도가 된다던가 해서 못 사용하거나 하지는 않았습니다. 제가 9.10은 사용해보지 않아서 모르겠습니다.

User avatar
떠돌이
Posts: 2911
Joined: 2008/04/27 Sun 10:39 am

Re: cpu 점유율 100% 우분투 9.10 좀 도와주세요~ 리눅서님들

Post by 떠돌이 » 2009/11/24 Tue 10:27 am

제 생각엔 펄스로 옮겨오면서 생긴 사운드서버의 문제 같은데.. 솔직히 짐작만 가능하지 무엇이 문제인지는 잘 모르겠습니다.

다른 mp3 프로그램에서도 그런가요?(gstreamer를 사용하지 않는)

Alt + F2 후 gstreamer-properties에서

설정을 ALSA나 다른 사운드서버로 바꾸는 것이 도움이 될지도 모르겠네요.(문제가 무엇인지를 모르므로 안될가능성이 높습니다)
Attachments
Screenshot.png
Screenshot.png (30.26 KiB) Viewed 1420 times

Post Reply