Page 1 of 1

nautilus-3.20.1 컴파일 에러에 대해 조언 부탁 드립니다.

Posted: 2016/05/24 Tue 9:32 pm
by workman729
이번에 nautilus-3.20.1 버전의 아이콘 gap을 조절 하기 위해 패치를 만들어 빌드하는 과정에
뜻하지 않는(? 알수 없는) 에러가 발생해서 고수님들의 조언 부탁 들립니다.

그림을 참조 하시기 바라면 python 쪽의 문제인지 아스키 코드가 있다하는 것으로 보아
python 쪽의 문제인 것 같습니다.

에러에 대한 정보가 있거나 참조할 만한 사이트의 정보를 가지고 계시다면
공유해 주시면 감사합겠습니다.

Re: nautilus-3.20.1 컴파일 에러에 대해 조언 부탁 드립니다.

Posted: 2016/05/25 Wed 3:11 am
by workman729
일단 python의 기본 엔코딩을 utf-8로 바로 잡아 주는 것으로 해결 하였습니다!

/usr/lib/python2.7/sitecustomize.py에 아래 라인을 추가 하였습니다.
[code:d5q9ibxp]import sys

reload(sys)
sys.setdefaultencoding('utf8')[/code:d5q9ibxp]
그런데 소스 패키징을 원천적으로 잘 못 하였군요!
ppa를 운영하는 애들은 어떻게 한 것 인지 모르겠습니다.