cpu 코어 하나만 계속 돌아가는 증상..대체 왜 이럴까요?

데스크탑 꾸미기(compiz)/소프트웨어 설치 및 설정에 관한 문제 해결

Moderator: Dry8r3aD

Post Reply
metdol
Posts: 11
Joined: 2013/05/16 Thu 11:31 pm

cpu 코어 하나만 계속 돌아가는 증상..대체 왜 이럴까요?

Post by metdol » 2016/03/05 Sat 12:10 pm

[attachment=0:325xp04v]
스크린샷, 2016-03-05 09-52-45.png
스크린샷, 2016-03-05 09-52-45.png (86.96 KiB) Viewed 2461 times
[/attachment:325xp04v]
노트북에 우분투를 설치해 사용중에 있는데요 쓰다보면 쿨링팬이 좀 빠르게 돌아가면서
버벅임이 좀 느껴진다 싶어서 확인해 보면 위 스샷에서 보이는것처럼 저렇게 cpu3번에서만 부하가 걸리네요
그래서 뭐가 문제인지 시스템 감시나 htop으로 프로세스를 확인해 보면 저렇게 높은 cpu 로딩이 발생할만한것은
전혀 보이지가 않습니다. 기껏해야 일시적으로 7%정도...
이런증상이 우분투 14.04때부터 나타났던것 같은데 우분투 자체에 문제가 있는건지 아님 다른 문제인건지
원인을 모르니 답답하기만 하네요..
이에 대해 검색을 해보니 저와 같은 증상을 보이는 한분이 질문을 올리셨던데 그분은 해결을
하셨는지 모르겠네요..ㅠㅠ
다른 분들은 이런 증상이 없는지 궁금합니다. 또는 이 문제를 해결하신 분이 계시다면 답글 좀 부탁드립니다.

metdol
Posts: 11
Joined: 2013/05/16 Thu 11:31 pm

Re: cpu 코어 하나만 계속 돌아가는 증상..대체 왜 이럴까요?

Post by metdol » 2016/03/05 Sat 8:21 pm

[quote="yogeebae":2b3urzy4]실은 저도 만년 왕초보인데요. 터미널에 $ top 실행해서 어떤 pid가 그리 나오는지 보시고,
$ ps aux | grep -i 4888 <=== pid번호 확인 해보시면 어떤 프로그램 때문에 그리 나오는지 알수 있을 것 같네요.
해결 방법은 그 이후에.....[/quote:2b3urzy4]

질문 내용에도 썼습니다만 그게 확인이 안돼요 그러니까 cpu는 분명 부하가 걸리고 있는데 시스템 모니터나 htop
그리고 님이 말씀하신 top로 각각 다 확인해 보면 스샷처럼 cpu를 많이 잡아먹는게 하나도 없습니다.
뭔가 보여야 해결할 실마리라도 찾을텐데 이건 뭐 보이지가 않으니 답답하네요..

metdol
Posts: 11
Joined: 2013/05/16 Thu 11:31 pm

Re: cpu 코어 하나만 계속 돌아가는 증상..대체 왜 이럴까요?

Post by metdol » 2016/03/05 Sat 10:10 pm

[quote="yogeebae":1ns5uv7w]우분투14.04 때부터 이런 증상이 나타난다 말씀하시는 것으로 미루어 볼때 우분투14.04는 분명 아닌것 같고, 그럼 우분투 버전은? 커널 버전은?
노트북 메이커는? cpu 종류는? 등등....의 자세한 정보가 없이 무턱대고 무엇이 안되요? 질문하시면 귀신인들 알수 있겠는지요?

P.S. 만년 초보라서 그리고 특별히 할일도 없고, 여러가지로 궁금해서 구글링 해봤습니다.
비슷한 증상이 있군요. 참고 해보세요. https://unix.stackexchange.com/question ... ant-in-top[/quote:1ns5uv7w]

우분투 14.04(최신 14.04.4까지 업글한 상태 였습니다.)를 쓰다가 혹시나 이문제가 해결될까 싶어 몇일전에 16.04 베타 버전을 설치한 상태입니다.
헌데 16.04에서도 이런 증상이 계속되서 답답함에 질문을 드리는 겁니다.
굳이 노트북 메이커나 cpu종류 까지 써야될 필요가 있을까 싶네요..문제 해결과는 상관 없는것 같아서..(msi 노트북에 인텔 cpu i5-4210m 입니다.)
그리고 무턱대고 질문을 드리는게 아니라 이것도 질문 내용에 있는 겁니다만 검색을 해보니 저와 같은 증상을 보이시는 분이 있어서 혹시나 다른 분들도
공통적으로 겪는 문제가 아닐까 싶어 질문을 드린거고 이문제를 해결한 분이 계시다면 도움을 얻고자 글을 올린겁니다.

User avatar
pukakk
Posts: 282
Joined: 2008/08/18 Mon 8:57 pm

Re: cpu 코어 하나만 계속 돌아가는 증상..대체 왜 이럴까요?

Post by pukakk » 2016/03/08 Tue 4:49 pm

희한하네요.
저는 i3, HP 노트북인데 아직 이런 것을 겪어본 적이 없는데,,,

혹시 내장 그래픽인가요? 그리고 그 내장 그래픽에 적합한 드라이버가 설치되어 있는지 확인해보세요.
올바른 그래픽 드라이버가 설치되어 있지 않고, VESA 드라이버로 돌아가는 거면 Xorg가 CPU를 혹사시킬 수도 있습니다.
수아야 네 원래 얼굴 어디갔니.. ㅠㅠ

metdol
Posts: 11
Joined: 2013/05/16 Thu 11:31 pm

Re: cpu 코어 하나만 계속 돌아가는 증상..대체 왜 이럴까요?

Post by metdol » 2016/03/08 Tue 6:09 pm

[quote="pukakk":14ac24n9]희한하네요.
저는 i3, HP 노트북인데 아직 이런 것을 겪어본 적이 없는데,,,

혹시 내장 그래픽인가요? 그리고 그 내장 그래픽에 적합한 드라이버가 설치되어 있는지 확인해보세요.
올바른 그래픽 드라이버가 설치되어 있지 않고, VESA 드라이버로 돌아가는 거면 Xorg가 CPU를 혹사시킬 수도 있습니다.[/quote:14ac24n9]

답변 감사합니다. 인텔 내장 그래픽입니다.(hd 4600)
적합한 드라이버가 설치 되어 있는지는 어떻게 확인하면 되나요?

User avatar
pukakk
Posts: 282
Joined: 2008/08/18 Mon 8:57 pm

Re: cpu 코어 하나만 계속 돌아가는 증상..대체 왜 이럴까요?

Post by pukakk » 2016/03/16 Wed 9:10 pm

[quote="metdol":2j7l1qoi]
답변 감사합니다. 인텔 내장 그래픽입니다.(hd 4600)
적합한 드라이버가 설치 되어 있는지는 어떻게 확인하면 되나요?[/quote:2j7l1qoi]

터미널에서 다음 명령을 치시면 됩니다.
[code:2j7l1qoi]sudo lshw -c video [/code:2j7l1qoi]

그럼 이런 식으로 나오는데...

[quote:2j7l1qoi]
*-display
description: VGA compatible controller
product: GM107 [GeForce GTX 750]
vendor: NVIDIA Corporation
physical id: 0
bus info: pci@0000:01:00.0
version: a2
width: 64 bits
clock: 33MHz
capabilities: pm msi pciexpress vga_controller bus_master cap_list rom
configuration: driver=nvidia latency=0
resources: irq:32 memory:fd000000-fdffffff memory:c0000000-cfffffff memory:d0000000-d1ffffff ioport:e000(size=128) memory:fe000000-fe07ffff
[/quote:2j7l1qoi]
configuration: driver=어쩌구저쩌구 latency=0로 나오는게 드라이버입니다.

generic vesa드라이버만 아니라면 올바른 드라이버를 사용하는 것일거에요.
수아야 네 원래 얼굴 어디갔니.. ㅠㅠ

metdol
Posts: 11
Joined: 2013/05/16 Thu 11:31 pm

Re: cpu 코어 하나만 계속 돌아가는 증상..대체 왜 이럴까요?

Post by metdol » 2016/03/16 Wed 9:57 pm

[quote="pukakk":28pduabc][quote="metdol":28pduabc]
답변 감사합니다. 인텔 내장 그래픽입니다.(hd 4600)
적합한 드라이버가 설치 되어 있는지는 어떻게 확인하면 되나요?[/quote:28pduabc]

터미널에서 다음 명령을 치시면 됩니다.
[code:28pduabc]sudo lshw -c video [/code:28pduabc]

그럼 이런 식으로 나오는데...

[quote:28pduabc]
*-display
description: VGA compatible controller
product: GM107 [GeForce GTX 750]
vendor: NVIDIA Corporation
physical id: 0
bus info: pci@0000:01:00.0
version: a2
width: 64 bits
clock: 33MHz
capabilities: pm msi pciexpress vga_controller bus_master cap_list rom
configuration: driver=nvidia latency=0
resources: irq:32 memory:fd000000-fdffffff memory:c0000000-cfffffff memory:d0000000-d1ffffff ioport:e000(size=128) memory:fe000000-fe07ffff
[/quote:28pduabc]
configuration: driver=어쩌구저쩌구 latency=0로 나오는게 드라이버입니다.

generic vesa드라이버만 아니라면 올바른 드라이버를 사용하는 것일거에요.[/quote:28pduabc]

친절한 답변 감사합니다.
그래픽 드라이버 문제는 아니었구요
별에별 방법은 다 써보다가 결국은 원인을 파악했는데
황당하게도 무선 랜카드 문제였네요..--;;
인식도 잘되고해서 전혀 생각을 못하고 있었는데 혹시나 싶어
유선으로 연결해 사용하니 언제 그랬냐는듯이 멀쩡해 지더군요..
윈도우상에서는 아무런 문제가 없는것으로 보아 드라이버에 문제가 있지 않나 싶네요
이런 증상이 오래 되었는데도 아직까지 이러는거 보면 앞으로도 해결될 가능성은 희박하지 않을까 싶습니다...ㅠㅠ
무선 랜카드는 Realtek RTL8723AE 제품입니다. 같은 제품 쓰시는 분들은 저처럼 원인을 찾겠다고 고생하지 마시고
유선으로 연결해 사용하시거나 무선 랜카드 교체를 권해 드립니다..--;;

workman729
Posts: 562
Joined: 2014/02/12 Wed 5:02 pm

Re: cpu 코어 하나만 계속 돌아가는 증상..대체 왜 이럴까요?

Post by workman729 » 2016/05/27 Fri 11:13 pm

우분투 커널 4.x 버전대의 버그로 알고 있습니다.

듀얼 또는 쿼드 cpu를 사용할 때 cpu 중 하나가 hang out되는 것으로 알고 있습니다.
특이 webkit2gtk를 사용할 때 자주 버그가 발생하는 것으로 알고 있으며
lightdm의 webkit-greeter를 사용하지 마시기 바랍니다.(즉각적으로 반응합니다.)

번외로 페도라에선 lightdm-gtk-greeter도 동일한 증상이 있더군요!

또한 xenial의 커널 버전대는 다 그럴 것으로 예상되고
종료시 몇 번 cpu에서 문제가 발생하는 지 로깅을 보여 줍니다.

커널 4.4.11 버전에서 패치가 된 것으로 알고 있습니다.
현재 저는 지금 이 커널을 사용하고 있으며 위의 증상이 전혀 일어나지 않고 있습니다.

되도록이면 바이오스에서 cpu 설정을 auto로 잡지 마시고 메뉴얼로 잡으시면 도움이 될 것 입니다.

이 버그는 페도라, 오픈수세, 우분투등이 4.4.x 버전대의 커널에서 모두 동일하게 발생하는 것을
직접 목도 하였습니다.

Post Reply