리눅스용 한글 2008을 우분투 15.04에 설치하기(amd64 아키텍처 기준)

데스크탑 꾸미기(compiz)/소프트웨어 설치 및 설정에 관한 문제 해결

Moderator: Dry8r3aD

Post Reply
User avatar
pukakk
Posts: 282
Joined: 2008/08/18 Mon 8:57 pm

리눅스용 한글 2008을 우분투 15.04에 설치하기(amd64 아키텍처 기준)

Post by pukakk » 2015/06/08 Mon 9:50 pm

1. 리눅스용 한글 2008 설치 CD-ROM에 들어있는 rpm 패키지를 모두 하드디스크에 복사한다.
2. alien을 설치한다
[code:2lhzr1kg]sudo apt-get install alien[/code:2lhzr1kg]
3. rpm을 deb 패키지로 전환한다
[code:2lhzr1kg]sudo alien -k .*rpm[/code:2lhzr1kg]
4. 전환된 deb 패키지를 64 비트 우분투로 가지고 온 다음 설치한다
[code:2lhzr1kg]sudo dpkg --force-architecture *.deb[/code:2lhzr1kg]
5. 첨부된 압축파일을 풀어서 /usr/lib/haansoft/lib 폴더에 복사한다.

끝.

*덧말 : 32비트 아키텍처에서도 리눅스용 한글2008에서 요구하는 라이브러리들을 /usr/lib/haansoft/lib에 설치하시면 됩니다.

단 이 글에 첨부된 압축파일내의 라이브러리들은 대부분 64비트 아키텍처용이라, 32비트 아키텍처용 라이브러리를 직접 구하셔야 될 겁니다.

https://launchpad.net/ubuntu/vivid/
Attachments
haansoft_lib_amd64.tar.gz
리눅스용 한글2008이 필요로 하는 라이브러리들입니다.(amd64 아키텍처용)
/usr/lib/haansoft/lib에 복사하세요.
(7 MiB) Downloaded 131 times
수아야 네 원래 얼굴 어디갔니.. ㅠㅠ

User avatar
pukakk
Posts: 282
Joined: 2008/08/18 Mon 8:57 pm

Re: 리눅스용 한글 2008을 우분투 15.04에 설치하기(amd64 아키텍처 기준)

Post by pukakk » 2015/12/15 Tue 12:11 pm

다른 것은 정상적으로 작동해도
인쇄하려고 할 때 튕기는 현상이 있을 수 있습니다.

이 때는 여러분이 쓰고 계신 CUPS 데몬의 버전이
/usr/lib/haansoft/lib에 들어있는 libcups와 맞지않을 경우에 발생합니다.

해결책은 /usr/lib/x86_64-linux-hpu/libcups.so.2를 /usr/lib/haansoft/lib에 복사하거나 소프트링크를 거시면 됩니다

(* 32비트 우분투를 사용하고 계시다면 /usr/lib/i386-linux-gpu/libcups.so.2를 복사하거나 소프트링크 거세요*)
수아야 네 원래 얼굴 어디갔니.. ㅠㅠ

Post Reply