12.04LTS 업데이트시에 에러가 납니다..ㅠㅠ 도와주세요

데스크탑 꾸미기(compiz)/소프트웨어 설치 및 설정에 관한 문제 해결

Moderator: Dry8r3aD

Post Reply
rednwhite
Posts: 205
Joined: 2008/07/08 Tue 8:08 am

12.04LTS 업데이트시에 에러가 납니다..ㅠㅠ 도와주세요

Post by rednwhite » 2014/11/24 Mon 11:56 am

12.04LTS를 사용중입니다.
제가 바이두 클라우드 프로그램을 설치하다가 에러가 났습니다.(그냥 시냅틱에 나와 있는 것만 설치하고 사용할 껄..ㅠㅠ 괜히 건드렸다가 사고쳤네요..)
프로그램출처는 아래 링크입니다.
https://github.com/LiuLang/bcloud-packages
더블클릭으로 설치를 했는데...
에러가 났구요..(무슨 에러인지 봐두었어야 하는데 못 봐두었습니다..ㅠㅠ)
그 이후로 프로그램 업데이트가 되지 않습니다..
업데이트 관리자를 실행시키면
아래와 같이 나오구요..
___________________________
[code:2jyq1g0d]업데이트 관리자
패키지 시스템이 망가졌습니다

일반적으로 문제의 원인이 되는 서드 파티 저장소를 사용 여부를 확인한 후 사용하고 있는 서드 파티 저장소를 사용하지 않도록 설정하십시오.또한 다음 명령을 터미널에서 실행하십시오: apt-get install -f
다음 패키지가 충족할 수 없는 의존성을 가지고 있습니다:

linux-generic: Depends: linux-image-generic (= 3.2.0.69.82) 하지만 3.2.0.70.84은(는) 설치했습니다
Depends: linux-headers-generic (= 3.2.0.69.82) 하지만 3.2.0.69.82은(는) 설치했습니다
linux-headers-generic: Depends: linux-headers-3.2.0-69-generic 하지만 설치하지 않았습니다.][/code:2jyq1g0d]
______________
저기서 시키는대로 apt-get install -f 를 실행하면
_________________________
[code:2jyq1g0d]rednwhite@Network-associated-storage:~$ sudo apt-get install -f패키지 목록을 읽는 중입니다... 완료
의존성 트리를 만드는 중입니다
상태 정보를 읽는 중입니다... 완료
의존성을 바로잡는 중입니다... 완료
다음 패키지가 자동으로 설치되었지만 더 이상 필요하지 않습니다:
linux-headers-3.2.0-29 linux-headers-3.2.0-29-generic libtorrent-rasterbar6
이들을 지우려면 'apt-get autoremove'를 사용하십시오.
다음 패키지를 더 설치할 것입니다:
linux-generic linux-headers-generic
다음 패키지를 업그레이드할 것입니다:
linux-generic linux-headers-generic
2개 업그레이드, 0개 새로 설치, 0개 제거 및 102개 업그레이드 안 함.
2개를 완전히 설치하지 못했거나 지움.
4,130 바이트 아카이브를 받아야 합니다.
이 작업 후 0 바이트의 디스크 공간을 더 사용하게 됩니다.
계속 하시겠습니까 [Y/n]?
받기:1 http://kr.archive.ubuntu.com/ubuntu/ precise-updates/main linux-generic amd64 3.2.0.70.84 [1,716 B]
받기:2 http://kr.archive.ubuntu.com/ubuntu/ precise-updates/main linux-headers-generic amd64 3.2.0.70.84 [2,414 B]
내려받기 4,130 바이트, 소요시간 0초 (8,497 바이트/초)
dpkg: 의존성 문제로 linux-headers-generic을(를) 설정할 수 없습니다:
linux-headers-generic 패키지는 다음 패키지에 의존: linux-headers-3.2.0-69-generic: 하지만:
linux-headers-3.2.0-69-generic 패키지는 설치하지 않았습니다.
dpkg: linux-headers-generic을(를) 처리하는데 오류가 발생했습니다 (--configure):
의존성 문제 - 설정하지 않고 남겨둠
보고서를 작성하지 않습니다. 오류 메시지에 따르면 예전의 실패 때문에 생긴 부수적인 오류입니다.
dpkg: 의존성 문제로 linux-generic을(를) 설정할 수 없습니다:
linux-generic 패키지는 다음 패키지에 의존: linux-image-generic (= 3.2.0.69.82): 하지만:
시스템에 있는 linux-image-generic의 버전은 3.2.0.70.84입니다.
linux-generic 패키지는 다음 패키지에 의존: linux-headers-generic (= 3.2.0.69.82): 하지만:
linux-headers-generic 패키지는 아직 설정하지 않았습니다.
dpkg: linux-generic을(를) 처리하는데 오류가 발생했습니다 (--configure):
의존성 문제 - 설정하지 않고 남겨둠
보고서를 작성하지 않습니다. 오류 메시지에 따르면 예전의 실패 때문에 생긴 부수적인 오류입니다.
처리하는데 오류가 발생했습니다:
linux-headers-generic
linux-generic
E: Sub-process /usr/bin/dpkg returned an error code (1)[/code:2jyq1g0d]
____________________
라고 나옵니다...ㅠㅠ
이런 상태로 거의 한달도 넘은 듯 합니다..ㅠㅠ
아시는 분 계시면 도와주세요.
감사합니다.[code:2jyq1g0d][/code:2jyq1g0d]

User avatar
강분도
Posts: 6059
Joined: 2008/03/31 Mon 5:47 pm
Contact:

Re: 12.04LTS 업데이트시에 에러가 납니다..ㅠㅠ 도와주세요

Post by 강분도 » 2014/11/25 Tue 12:49 am

혹시 제가 아는 대장 내시경 잘하시는...? :mrgreen:

설치 후 오류를 해결하려면 설치하신 걸 제거 하면 되는데...
[list=1:2tfafxda][*:2tfafxda]우선 깃허브에서 설치하신 바이두 클라우드를 제거해야 할 듯합니다.
sudo dpkg -r bcloud
그런 후에
sudo apt-get update

[/*:m:2tfafxda]
[*:2tfafxda]그러고도 에러 난다면 아래 방법으로 제거를..
sudo sudo apt-get --purge remove bcloud
그런 후에
sudo apt-get update[/*:m:2tfafxda][/list:o:2tfafxda] 해보십시요

위는 제거 하는 거 설명 해보았구요 링크 걸어 주신 깃허브꺼 설치 하려면
[list:2tfafxda]
[*:2tfafxda] sudo apt-get update
[/*:m:2tfafxda]
[*:2tfafxda] sudo apt-get install python3-dev
[/*:m:2tfafxda]
[*:2tfafxda] sudo apt-get install python3-setuptools
[/*:m:2tfafxda]
[*:2tfafxda] sudo easy_install3 pip
[/*:m:2tfafxda]
[*:2tfafxda] sudo pip3 install --upgrade pycrypto
[/*:m:2tfafxda]
[*:2tfafxda] sudo pip3 install --upgrade keyring[/*:m:2tfafxda][/list:u:2tfafxda] 오래된 12.04에서 오류가 나니 위 순서대로 해주라고 하는 듯합니다. :?


아 그리고 현재 12.04.[b:2tfafxda]5[/b:2tfafxda] 상태인가요? 확인은 lsb_release -a 명령어입니다. 아니라면 최신 상태로 업데이트(오래된 12.04에서 업데이트)해주시기 바랍니다.
sudo apt-get update
sudo apt-get upgrade
P.S : 위 명령어는 자동알림으로 업데이트 되는데...

User avatar
강분도
Posts: 6059
Joined: 2008/03/31 Mon 5:47 pm
Contact:

Re: 12.04LTS 업데이트시에 에러가 납니다..ㅠㅠ 도와주세요

Post by 강분도 » 2014/11/25 Tue 12:53 am

위 설명을 너무 터미널 위주로 했는데... GUI에서
시냅틱관리자(synaptic)에서도 할 수 있고
또 lsb_release -a 같은 명령어도 시스템 정보(시스템모니터)에서 볼 수 있습니다.

rednwhite
Posts: 205
Joined: 2008/07/08 Tue 8:08 am

Re: 12.04LTS 업데이트시에 에러가 납니다..ㅠㅠ 도와주세요

Post by rednwhite » 2014/11/26 Wed 9:28 am

강분도님 감사합니다.

예...그 대장내시경하는 rednwhite입니다..^^;;

어제 저녁에는 퇴근이 늦어서 퇴근하자마자 뻣어 자느라고 못해봤습니다.

오늘 퇴근하면 시도해보고 글 남기도록 하겠습니다.


알려주셔서 감사합니다.

rednwhite
Posts: 205
Joined: 2008/07/08 Tue 8:08 am

Re: 12.04LTS 업데이트시에 에러가 납니다..ㅠㅠ 도와주세요

Post by rednwhite » 2014/11/27 Thu 10:03 am

[quote="rednwhite":1mtkjfyw]어제 저녁에는 퇴근이 늦어서 퇴근하자마자 뻣어 자느라고 못해봤습니다.

오늘 퇴근하면 시도해보고 글 남기도록 하겠습니다.
[/quote:1mtkjfyw]

어제 퇴근해서 컴터도 못 켜보고 잤습니다.ㅠㅠ

연말이라 그런지 바쁘네요.

반드시 해보고 리플달도록 하겠습니다..

rednwhite
Posts: 205
Joined: 2008/07/08 Tue 8:08 am

Re: 12.04LTS 업데이트시에 에러가 납니다..ㅠㅠ 도와주세요

Post by rednwhite » 2014/11/27 Thu 7:37 pm

[quote="강분도":7vns715u]설치 후 오류를 해결하려면 설치하신 걸 제거 하면 되는데...
[list=1:7vns715u][*:7vns715u]우선 깃허브에서 설치하신 바이두 클라우드를 제거해야 할 듯합니다.
sudo dpkg -r bcloud
그런 후에
sudo apt-get update[/quote:7vns715u]

[code:7vns715u]rednwhite@Network-associated-storage:~$ sudo dpkg -r bcloud
[sudo] password for rednwhite:
Sorry, try again.
[sudo] password for rednwhite:
dpkg: 경고: there's no installed package matching bcloud[/code:7vns715u]


[quote="강분도":7vns715u][/*:m:7vns715u][*:7vns715u]그러고도 에러 난다면 아래 방법으로 제거를..
sudo sudo apt-get --purge remove bcloud
그런 후에
sudo apt-get update[/*:m:7vns715u][/list:o:7vns715u] 해보십시요[/quote:7vns715u]

[code:7vns715u]rednwhite@Network-associated-storage:~$ sudo apt-get --purge remove bcloud
패키지 목록을 읽는 중입니다... 완료
의존성 트리를 만드는 중입니다
상태 정보를 읽는 중입니다... 완료
E: bcloud 패키지를 찾을 수 없습니다
[/code:7vns715u]

아무래도 blcoud설치하다가 에러났던 것이 아예 설치가 되지 않았다는 에러였나 봅니다.
설치는 안되고 에러는 나고 업데이트는 막히고..ㅠㅠ

혹시 해결에 도움이 될 만한 생각 있으시면 가르쳐 주세요..

[quote="강분도":7vns715u]아 그리고 현재 12.04.[b:7vns715u]5[/b:7vns715u] 상태인가요? 확인은 lsb_release -a 명령어입니다. 아니라면 최신 상태로 업데이트(오래된 12.04에서 업데이트)해주시기 바랍니다.[/quote:7vns715u]

[code:7vns715u]rednwhite@Network-associated-storage:~$ lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 12.04.5 LTS
Release: 12.04
Codename: precise
[/code:7vns715u]

이렇게 나옵니다.

User avatar
강분도
Posts: 6059
Joined: 2008/03/31 Mon 5:47 pm
Contact:

Re: 12.04LTS 업데이트시에 에러가 납니다..ㅠㅠ 도와주세요

Post by 강분도 » 2014/11/27 Thu 10:23 pm

Description: Ubuntu 12.04.5 LTS
12.04.5로 업데이트는 잘 되어 있군요


우선
sudo apt-get autoremove
sudo apt-get update
sudo apt-get upgrade
해보시고요



그러고도 오류 난다면 설명에 나오는 말대로
[quote="rednwhite":25rzlwr3]일반적으로 문제의 원인이 되는 서드 파티 저장소를 사용 여부를 확인한 후 사용하고 있는 서드 파티 저장소를 사용하지 않도록 설정하십시오.[/quote:25rzlwr3]
위 말대로 하는 법은
[b:25rzlwr3]소프트웨어소스[/b:25rzlwr3] /기타소프트웨어에서
[img:25rzlwr3]http://ioriy2k.pe.kr/wordpress/wp-content/uploads/2012/06/04-Software-Source-Software.png[/img:25rzlwr3]
추가 되어있는 소스 체크를 없애고
sudo apt-get update
sudo apt-get upgrade
sudo apt-get install -f 또는 sudo apt-get autoremove 해보십시오
위 첨부 그림 및 방법 추가 설명 URL : http://happyppiggy.tistory.com/210

rednwhite
Posts: 205
Joined: 2008/07/08 Tue 8:08 am

Re: 12.04LTS 업데이트시에 에러가 납니다..ㅠㅠ 도와주세요

Post by rednwhite » 2014/11/28 Fri 6:45 am

됩니다.!!!

가르쳐주신대로 하니 됩니다.!!!


되는 것이 너무 기뻐서 터미널 화면만 멍하니 쳐다보다가 터미널화면 복사하는 것을 깜빡했네요.(터미널의 스크롤바를 올려도 이전 내용이 다 나오는 것은 아니더군요)

링크 걸어주신 내용대로 하고

sudo apt-get autoremove
sudo apt-get update
sudo apt-get upgrade


를 2번하니 됩니다.(첫번째 할 때는 왜 그런지 에러가 나더라구요)

되니까..106개인가? 밀려있던 업데이트가 한꺼번에 되면서 터미널 화면을 채우네요..


가르쳐 주셔서 감사합니다.


바이두 클라이언트 설치는 주말에나 다시 시도해 볼까?
또 에러나면서 업데이트가 막히면 어쩌나?

고민중인데..

아마도 주말에 설치를 시도해 볼 듯 합니다..


도와주셔서 감사합니다.

Post Reply