grub 부트로더 문제

우분투 설치 및 부팅과 관련된 문제 해결

Moderator: Dry8r3aD

Post Reply
zxcvbnmin
Posts: 7
Joined: 2019/03/06 Wed 2:16 pm

grub 부트로더 문제

Post by zxcvbnmin » 2019/03/20 Wed 1:06 am

제가 부트로더를 잘못 설치한거같아서 질문드립니다ㅠㅠ
apt-get update 와 apt-get upgrade를 하여 리눅스를 업데이트 하는 도중에 grub을 설치하라는 메세지가 떴었습니다.
설치하라는 폴더는 /dev/sda와 /dev/sda1 이었습니다.

그래서 저는 'fdisk -l' 로 현재 디스크 확인하였고 /dev/sda1가 있었으며, 목록 Boot에 '*' 표시가 있길래 /dev/sda1를 선택하고 설치를 하였습니다.
맞게 설치한 걸까요?

구글링 하였더니 어떤분은 /dev/sda로 설치하였더라구 하더라구요
/dev/sda/가 맞는것 같기도 합니다 ㅠㅠ 왜냐하면 둘다 메모리 용량이 비슷했거든요.

잘못 설치했더라면 해결법 좀 알려주세요ㅠㅠ 고수님들
어떻게 설치한 리눅스인데 재설치하기 싫어요~~ㅠㅠㅠ

User avatar
황병희
Posts: 571
Joined: 2009/10/18 Sun 1:47 am

Re: grub 부트로더 문제

Post by 황병희 » 2019/03/21 Thu 11:20 pm

제가 크롬북이라 도움이 못되서 송구스럽네요,,,
크롬북에 깔린 우분투는 그냥 CTRL+ALT+{F1|F2} 등으로 크롬OS/우분투 왔다갔다 할 수 있어요.
GRUB 자체가 없습니다.

하시는 칼리리눅스 공부 잘 되시길 멀리서 응원합니다!!!

[본 댓글은 크롬OS 에서 작성했씁니다]
ㄱㅅㅎㄴㄷ!

narang
Posts: 21
Joined: 2018/10/06 Sat 11:51 am

Re: grub 부트로더 문제

Post by narang » 2019/03/22 Fri 2:45 am

둘 중 어느 게 맞고 어느 게 틀린 게 아니라, 두 가지 다 가능합니다. 차이는 있겠습니다만... 그 차이는 구글님게 물어보시면 ...

zxcvbnmin
Posts: 7
Joined: 2019/03/06 Wed 2:16 pm

Re: grub 부트로더 문제

Post by zxcvbnmin » 2019/03/22 Fri 4:27 pm

윗 두분 답변 너무 감사합니다~!! :D

/dev/sda 설치가 맞다하네요

근데 이미 /dev/sda1에 설치했는데 복구나 재설치 방법이 없을까요?ㅠㅠ
너무 찜찜하네요

아니면 그냥 나중에 업데이트 하면서 grub 설치 뜨면 그때 다시 sda에 설치해도 문제 없을까용...

리눅스 접근 너무 어렵슴다..ㅠ

User avatar
황병희
Posts: 571
Joined: 2009/10/18 Sun 1:47 am

Re: grub 부트로더 문제

Post by 황병희 » 2019/04/05 Fri 11:53 am

황병희 wrote:
2019/03/21 Thu 11:20 pm
크롬북에 깔린 우분투는 그냥 CTRL+ALT+{F1|F2} 등으로 크롬OS/우분투 왔다갔다 할 수 있어요.
정정합니다.
CTRL+ALT+SHIFT+{F1|F2} 입니다^^^

꾸벅,,,

[크롬OS 에서 작성했습니다]
ㄱㅅㅎㄴㄷ!

Post Reply