apt-get upgrade할때의 메세지..

우분투 설치 및 부팅과 관련된 문제 해결

Moderator: Dry8r3aD

Post Reply
iloveapink
Posts: 18
Joined: 2016/03/21 Mon 10:21 am

apt-get upgrade할때의 메세지..

Post by iloveapink » 2016/07/16 Sat 5:59 am

민트를 사용중인데요.
sudo apt-get upgrade할때 꼭 아래와 같은 메세지가 나오는데 이거 없앨려면 어떻게 해야하나요?

[quote:244pewmt]
다음 패키지를 과거 버전으로 유지합니다:
shim-signed
[/quote:244pewmt]

workman729
Posts: 562
Joined: 2014/02/12 Wed 5:02 pm

Re: apt-get upgrade할때의 메세지..

Post by workman729 » 2016/07/16 Sat 10:00 am

그런 경우는 의존성으로 인한 다른 패키지가 그 시간에 아직 준비되지 않았거나
업데이트 대상의 패키지가 propose 형식의 패키지이거나
패키지 자체의 provider를 만족 시키지 못한 경우에 나옵니다.

거의 대부분은 apt-get dist-upgrade 명령으로 업데이트 시킬수 있습니다.
업데이트 대상의 패키지가 위에서 말씀 드린 어느 경우에 해당하는 지는 본인이 판단해야 합니다만

90%는 특별한 경우가 아니라면 dist-upgrade 명령으로 해소될 수 있습니다.

iloveapink
Posts: 18
Joined: 2016/03/21 Mon 10:21 am

Re: apt-get upgrade할때의 메세지..

Post by iloveapink » 2016/07/16 Sat 5:09 pm

답변 감사드립니다.
dist-upgrade하니까 해결됐습니다.
덕분에 하나 또 배워가네요.

Post Reply